tongrenche.com
当前位置:首页>>关于tomcat与jdk的版本匹配的资料>>

tomcat与jdk的版本匹配

java_home:c:\programfiles\java\jdk1.6.0path:c:\programfiles\java\jdk1.6.0\binclasspath:.;c:\programfiles\java\jdk1.6.0\lib\dt.jar;c:\programfiles\java\jdk1.6.0\lib\tools.jar;tomcat_

我们现在的实施全部都是jdk1.5_bulid12+tomcat5.0.30,非常稳定,不求高级,只求稳定.稳定性是系统的死穴.

我的也是1、6版本的 Tomcat 5.5.20 汉化版 感觉不错

你用的是什么操作系统呀, 你配置了PATH就不要再去配置JAVA_HOME 并且classpath也不要去配置,JAVA启动时会自动找到那个RT.JAR包,classpath是在当你的JAVA程序是需另外类包时才指定的,如果你没有超出RT.JAR包的话,无需进行配置.

首先你要安装jdk , jdk和eclipse要和电脑系统位数匹配: 32位或者64位.默认安装就行了 第二步 : 配置环境变量,方法如下: 三个环境变量的名字和值, 右键【我的电脑

配置好jdk就可以了 具体方法: 我的电脑->右键->属性->高级->环境变量->系统变量 添加2个变量 1)变量名:java_home 变量值:d:\jdk目录 2)变量名:classpath 变量值:.;d:\jdk目录\lib\dt.jar;d:\jdk目录\lib\tools.jar

tomcat5需要jdk5.0以上包括5.0tomcat6需要jdk6及以上不过有的时候也有可能出现点小问题啊比如tomcat5.5和jdk1.5配合的时候,可能就会出现问题.解决这个问题的方法:copy jdk1.5的lib/tools.jar到tomcat5.5的common/lib/tools.jar,覆盖掉原有文件就可以了.

tomcat9支持:jdk8(含)以下版本;tomcat8支持:jdk7(含)以下版本;tomcat7支持:jdk6(含)以下版本;你根据自己的环境来选择.

有关系的.比如tomcat7,对应的jdk就是1.7.tomcat8,对应的就是jdk1.8 依次类推

一一对应的就好,比如tomcat7 和jdk7.jdk可以向下兼容tomcat,tomcat5 6 7 也可以用jdk7

9371.net | qhnw.net | dzrs.net | yydg.net | tongrenche.com | 网站首页 | 网站地图
All rights reserved Powered by www.tongrenche.com
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com